2003 WR450 weird running problem


2 replies to this topic
  • WR450F_No28

Posted September 28, 2009 - 11:48 AM

#1

Friends 2003 WR450F. I am a decent but no genius mechanic. I have a 2006WR and have been its mechanic...great bike.

2003 bike was stock when he bought it. (looked hardly ridden) Ran very poorly overall.
It has the stock carb, with new jetting mods by me (jetted for 4k altitude-basically mirrors my 06 WR, which is very good.) Float seems ok, i checked as best i could. Float bowl had a hairline crack where drain seats..fixed (JB weld) and not leaking. replaced accelerator pump diaphragm which was corroded (weird!). Put in a throttle stop (it did not have one...used my old stock one that is cut to 22mm). bike did NOT have the warranty mod on the flywheel. Had that done by untrustworthy local yammie shop recently. i did not check valves yet. stock pipe, with aftermarket tip (pretty quiet)...

Bike now starts GREAT, with or without button. 0-1/2 throttle..thing pulls fantastic! probably stronger than mine. .5-.7 throttle..pretty good, but sputters somewhat. .7-full throttle, thing sputs and sputters and is generally pissed off. Have been pulling my hair out with this. Tried removing exhaust tip..no difference. Tried disconnecting throttle sensor..no change. Tried different gas...nope. I tried other things i am not remembering i am sure....still nothing. New plug..no difference...grrrr

Drat! Yamaha shop is no help. It is as tho it is bad gas, or being starved for fuel (float?) at high rpm or ? perhaps i should check valves...(I adjust my own-easy as you know) bike is at friends house so i cannot get personal with it to find this darn problem...maybe i should borrow for a month.

Any thoughts or ideas are greatly appreciated. My (and many other friends) WRs really do run fantastic at all rpm, here, or on the top of the highest trails we ride 9000' + I personally think WRs are some of the best bikes out there, and would be THE best if they were not so darn heavy.

Thanks for any thoughts.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • William1

Posted September 28, 2009 - 01:23 PM

#2

Sounds like you are running rich, assuming this is not the dreaded WR steady throttle stutter. Try lowering the needle 2 clip positions and see if that helps. Had it been lean, it would not stutter, it would just fall flat on its' face like a bog.

While you are messing with the needle, make note of what needle code it is.

  • mtndirtrider

Posted September 30, 2009 - 04:39 PM

#3

Hey man , I had a 03 wr 450. best bike I ever had. miss it.
any ways the 03 can jetted very lean factory.
richen the leak jet 1 step easier starting. richen the pilot 1 step and richen the main 4 #s drop the needle to 4th position . A use a zip tye fuel screw and your tunig will be greatly eased. good luck bro.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.