m8's 2001 426 very sick :(


No replies to this topic
  • Thylacine

Posted September 22, 2009 - 09:39 PM

#1

Hi all, a M8 of mine has this 426, after a hard ride recently it started blowing black smoke on the way back. when he got it of the trailer at home he discovered it was blowing fuel out the pipe as well. We are guessing its valve trouble and most likely rings as well. We are not mechanics however and i was just wondering if any one here would know exactly what the problem is, and maybe someone could point me to a good guide on repairing this problem. He doesnt have the spare cash at the moment to take it into the shop so we are going to have a crack at repairing it our selves. :busted:

Cheers. :L





Related Content

Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.