Jetting issues on Pilot Circuit



3 replies to this topic
  • gloft

Posted April 06, 2003 - 02:52 PM

#1

I'm getting a lot of low-end bog and stalling - especially after bike gets good and hot. Bike idles well, starts well but stalls a lot in slow, technical stuff. Seems to occur when I roll on the throttle as you might do when crossing a large rock or log. According to the manual, I should tune the pilot circuit so I plan on adjusting the fuel screw. Bike runs great from 1/4 throttle on up. Just need to get the low end dialed. Any ideas are much appreciated! BTW, I ride mostly between 1000 - 3000 ft elevation.
:)

  • utvols

Posted April 06, 2003 - 03:30 PM

#2

What are your jetting specs and how high is your idle set?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gloft

Posted April 06, 2003 - 03:46 PM

#3

Right now jetting is stock. Need to check idle, but it should be at stock setting as well.

  • gloft

Posted April 07, 2003 - 07:03 AM

#4

Idle is still at stock per WR450 manual. I'm going to remove the carb later today and clean and rejet. Anyone have any tips on carb maintenance outside of this wonderfull Japanese manual.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.