WR 450 2003, smokes ALOT!

4 replies to this topic
  • Torger123

Posted August 27, 2009 - 08:33 AM


my wr 450 is running nice but smokes ALOT and are burning engine oil.. someone who have had the same problem? is it just the valve gasket thing? (not so good in english=) what can be the problem since the engine has no other problem than smoking, i cant drive the bike because it will be oil empty very fast and i know its not normal to smoke that mutch.

  • William1

Posted August 28, 2009 - 02:14 AM


Sounds like the rings are gone. Time to pull the engine aprt and inspect it.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • CanadianWR450

Posted August 28, 2009 - 03:02 AM


I had the same problem, and it was rings....make sure you check the cylinder as well...if it's smooth, and no cross hatch left...replace it or re plate it...I learned that part the hard way........

  • Thermos O flask

Posted August 28, 2009 - 06:05 AM


Get your valves and valve guides checked as well,bet they will be rooted.

  • Torger123

Posted August 28, 2009 - 07:23 AM


hmm, the piston and rings are all new, but i noticed somting strange with the oil expander ring, (the ring that holdes the two small ones from each other) had a 10 mm end gap.. on the old piston it was 0-1 mm end gap on the ring.. can this be a production "error" or what its called?=) thnx for all the replyes


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.