Head pipe not fitting

No replies to this topic
  • WNY_06S3

Posted August 11, 2009 - 09:01 AM


Had a hole in the head pipe of my yoshimura titanium head pipe. Ordered a new stainless one (because of the cost difference) and when I went to put it on it doesn't fit correctly. There is about 1/8th inch free play between the exhaust port on the motor and the pipe when it's tightened up. I've tried to seat it several times with the same results. I will be calling yoshimura later today about the problem, but has anyone else ever had a problem like this?

Related Content


yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.