1996 suzuki rm80 fouling plugs


7 replies to this topic
  • dsmith8926

Posted July 26, 2009 - 02:02 PM

#1

hello i just bought a race ready suzuki rm80. everything is pretty much raceing on it except it has a stock exaust. yesterday when i got it i rode it for about 3 hours then and put it in the shed and this morning i got it out and it wouldnt start. i figured it was a fouled out plug and it was. i changed it and it started first kick. i rode it for about a half an hour and the new plug fouled out. the previous owner said the bike has had a history of fouling plugs. any idea why this is happening?

  • TheSuzukiRider

Posted July 26, 2009 - 04:00 PM

#2

jetting maybe? try a slightly hotter plug like 9 maybe 8

  • dsmith8926

Posted August 01, 2009 - 11:04 AM

#3

what do you mean by a hotter plug? i buy my spark plugs from napa and basicly just use what they give me. sorry i dont know to much about dirrt bikes.

  • mihylo33

Posted August 02, 2009 - 06:08 AM

#4

NGK b10es is the plug your bike calls for. I would start there. you may be lugging the motor causing a build up and fouling the plugs. there is also what they call a dry foul. this is when the plug gets too hot and burns itself out.

  • killerdwarf77

Posted August 02, 2009 - 06:58 AM

#5

What oil is being used, and at what ratio is it being mixed at? How hard are you running the bike? What kind of riding are you doing? Track? trail? Are you a beginner rider? Be honest with your answers, and we can send you in the right direction.

  • dsmith8926

Posted August 03, 2009 - 09:03 PM

#6

ngk br10es were the plugs i were useing. they kept fouling out. im useing castrol high performance 2 cycle oil, i was running it at 32:1 but now i am running 40:1

i think i run the bike pretty hard. im always hitting the power band and topping it out in every gear before i shift. i do a lot of trail rideing with a lot of stright aways, but some tight corners. ive had about 6 years of rideing exsperience on my yamaha blaster and my xr80r so idk if you guys would consider me a begginer rider or not

thanks for your help guys i really appreciate it.

  • mihylo33

Posted August 04, 2009 - 02:46 AM

#7

im useing castrol high performance 2 cycle oil, i was running it at 32:1 but now i am running 40:1

i think i run the bike pretty hard. im always hitting the power band and topping it out in every gear before i shift.
.


Go back to the original 30:1 ratio before you have bigger problems than a fouled plug.

Clean the air filter and the carb then read the FAQ's sticky on jetting in this forum. It may also be as simple as the brand of oil you use. I have no experience with th Castrol so I cannot comment on the quality, but it does sound like its made for a twin cylinder street bike, like an RZ or something.

  • killerdwarf77

Posted August 04, 2009 - 04:59 AM

#8

Try a #9 plug, and lose the Castrol. I find it's a very dirty running oil. I knew someone who ran it in his sled because it was cheap. Yes, he fouled plugs quite often. Eventually smoked his motor too! Run instead a good synthetic oil such as Amsoil Dominator, Maxim, Ipone, Silkolene, Klotz etc. Mix it at 40-1 and see if it helps. If it doesn't then start playing with the carb.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

RegisterSign InClose
If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.