Wr450f Tps problem!?


6 replies to this topic
  • curveball323

Posted July 01, 2009 - 07:13 AM

#1

I have had this stutter in my bike ever since i received it from sea level. I live at about 4,500 ft and the bike has just been acting up. not too bad though. it's a used but almost new 07 wr450f. with all of the free mods. grey wire throttle stop bored exhaust you know. we thought that the stutter might be because of the jetting so we changed the main jet from 175 to a 160 we actually tried lots in between but it kept getting better everytime we changed them. so we finnally stopped at 160. we also changed the pilot jet to 48 i believe from 60. the bike is alot better with the newer jetting but still has that stutter at high RPMs. it just BUGS ME. some guys said it is a classic wr stutter. they said to remove the Throttle position sensor. TPS. so i took my bike apart and disconnected it.. IT RAN GREAT WITH NO STUTTER!!! It still has alot of power. but i hear that once you disconnect it you loose 20%. I would really like to reconnect it and adjust it so the stutter is gone and i get that final 20% power. I read the manual but some of it doesn't make anysense. when i start it to check if it's between. .58 and .78 volts does the coupler need to be connected? do i have to do it from behind the coupler? if so how in the world do you get behind it? there is a stock green mark on the TPS that is lined up so i really wonder how far off it is? I would really apreciate any light on this situation thanks!!

  • ranger85

Posted July 01, 2009 - 08:56 AM

#2

I also get that stutter every now and then at high rpms with light throttle. I checked my TPS output voltage and it was at .68. They say to set it to the higher range but I left mine alone since I go from below 5000 feet riding and above 11,000 feet and the temps fluxuate around here so much which plays a role on the voltage output. I have also had luck with disconnecting it, but you can, at the very slightest, feel a slight drop in low end performance. So I just left it connected and will live with it till I fork out $400 for a Vortex ignition one of these days. If I recall you disconnect the coupler and stick the positive lead on your multimeter down through that green waterproof rubber piece to the yellow wire, and the negative lead to the black wire(On the backside, on the wire coming from the carb). Try to only do this once or it will mess up that waterproof green rubber piece. Then crank the bike up and check the readings.

  • SJMC_DON

Posted July 01, 2009 - 10:03 AM

#3

I don't think you can adj the TPS to get rid of the stutter...

Yes, I sense a slight decrease in low end responsiveness with it un plugged but consider it a good trade off.

Someone said here once that it can be done with a particular CDI, (perhaps Vortex) and then on only one of the mapping settings will you lose the stutter.

I am considering an in line switch so that I can turn the TPS off / on on the fly. :worthy:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • WR_Dave

Posted July 02, 2009 - 05:49 AM

#4

This has nothing to do with the high end stutter, but if you are at 4500ft and above, then I would suggest going to a 42 pilot or maybe even a 40 for the low end response. I found that changing to the previous years YZ 450 jet needle and running it one clip richer ( 3rd fronm the top) with a 165 main jet took all of the issues away from "MY" '07 WR. Just another opinion. WR Dave

  • Thumper_Bloke

Posted July 02, 2009 - 08:34 AM

#5

Yet another option is a CDI from Dynatek.

  • curveball323

Posted July 02, 2009 - 03:50 PM

#6

These are some great Ideas I will have to try them. Yeah I'm not a pro at tweaking the carb but I feel like i know what is going on inside of it. so I will try the pin position. But I'm loving the feel of the bike without the TPS connected. It's a great trade off for the low RPM responsiveness. At one point i couldn't even get the bike past 40 MPH even at full throttle because that stutter just got bad. but ever since i lowered the main jet and switched the pilot .. i got it up to 80 MPH i bet i could have gone faster too

  • ranger85

Posted July 02, 2009 - 05:23 PM

#7

Yet another option is a CDI from Dynatek.


Thumper, has this ignition been proven to get rid of the famous TPS stutter? If so that would be cool, cause I think I can get Dynatek cheaper than Vortex, but that's the first I've heard of Dynatek for this issue. I have a Dynatek on my Raptor and LOVE it.

Thanks.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.