oil cooler install


8 replies to this topic
  • sab24711

Posted 19 June 2009 - 03:23 PM

#1

well just like the title says i bought an oil cooler for my pit bike but no instructions came with it. i have a lifan 125cc start neutral engine. i know i have to drill and tap lines but where. if anyone have detailed instructions that would be helpful.

  • staggsracing

Posted 19 June 2009 - 04:10 PM

#2

we need more info. what oilcooler and what bike??? maybe post some pics so we can help out.

  • T Bolt USA

Posted 19 June 2009 - 06:24 PM

#3

first off none of the oil cooler kits we sell require drilling

most 125 pitbike oil cooler come off the head with a bolt on plate

  • staggsracing

Posted 19 June 2009 - 07:22 PM

#4

Or Into The Case Of The Motor

  • sab24711

Posted 21 June 2009 - 01:48 AM

#5

Posted Image

Posted Image

Posted Image

Posted Image

not bad for a camera phone HUH? but yea that's what i have to work with.its more of a cheaper one i just bought but they if it works sweet deal. i only bought two bikes for 50 bucks pieced them together to make one cool bike if you need more pics let me know its 6 am long night and last thing before bed.

  • T Bolt USA

Posted 21 June 2009 - 07:29 AM

#6

bro
you need a oil head plate that taped 10mm
http://tboltusa.com/...products_id=695
we have them in stock in silver/aluminum and others in billet red

  • staggsracing

Posted 21 June 2009 - 07:46 AM

#7

your going to run into another problem your going to have to make some kind of bracket to hold it also as it doesn't look like your frame has one?

  • sab24711

Posted 21 June 2009 - 10:30 AM

#8

no way man its all good. why buy it, ill make both tbolt usa makes em so can i and a bracket is no problem its just how far way and where i can put it, but i like the fact i don't have a bracket just that much more different from your bike. but thank you now i know where to drill the holes.

  • sab24711

Posted 21 June 2009 - 11:08 AM

#9

hold on maybe you guys can help me again. my problem now is the motor seems to be running hot cause the pipe likes to change color throughout the exhaust. once i start it let it warm up with the choke on, ill take it out and it will run first gear but once i get on it in second it like to bog out. i have been messing with the fuel screw and the needle for most of the day. stock everything carb, jets, exhaust idk im at a stand still now.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

Register Close
If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.