1990 dodge cummins alternator


27 replies to this topic
  • aakmetz

Posted June 04, 2009 - 06:49 AM

#1

pulling my hair out, i'm a mech for 30yrs now, customer's truck not charging, all wiring and such in spec. 2 reman alternators, 2 new alternators, from napa, no charge condition, bench test them, all bad............ anyone else in the business ever experience such stuff. has QC gotten this bad? all made in mexico. nothing against them but i'm at wits end.:crazy:

  • YzGuy79

Posted June 04, 2009 - 08:15 AM

#2

pulling my hair out, i'm a mech for 30yrs now, customer's truck not charging, all wiring and such in spec. 2 reman alternators, 2 new alternators, from napa, no charge condition, bench test them, all bad............ anyone else in the business ever experience such stuff. has QC gotten this bad? all made in mexico. nothing against them but i'm at wits end.:crazy:


YES it has! Have you noticed the POS Detroit has been churning out these last few years?

  • aakmetz

Posted June 04, 2009 - 08:42 AM

#3

YES it has! Have you noticed the POS Detroit has been churning out these last few years?

yes i have, and it has allowed my family and I to take some nice tropical vacations:worthy: :crazy:

  • bronc3

Posted June 05, 2009 - 05:37 AM

#4

Multiple consecutive defects with replacement parts can definitely drive you crazy, causing you to second guess your diagnosis. I had it happen to me once with a drivability issue on a GM truck. Thought I had dropped the ball on diagnosing it, but it turned out to be a string of defective parts.

  • aakmetz

Posted June 05, 2009 - 05:50 AM

#5

i'm hanging, napa reman techline said its the ecm not the alternator.............duh, its a non-ecm mechanicaly fueled cummins, this is the crap i deal w/ all the time. i think i need to retire, but i love my job:banghead: :crazy:

  • bronc3

Posted June 05, 2009 - 07:25 AM

#6

I didn't think the '90 was electronic; I know Crysler in their infinite wisdom likes to put the voltage regulator in the ECM itself. I've seen many failures; customers love the expense of replacing the ECM for a simple voltage regulator failure.

If you replace the alternator with an internal regulator model it works, but you wind up with an eternal check engine light.

  • aakmetz

Posted June 05, 2009 - 07:34 AM

#7

I didn't think the '90 was electronic; I know Crysler in their infinite wisdom likes to put the voltage regulator in the ECM itself. I've seen many failures; customers love the expense of replacing the ECM for a simple voltage regulator failure.

If you replace the alternator with an internal regulator model it works, but you wind up with an eternal check engine light.

yes i heard of such, k-cars? lebaron, charger, this is a plain Cummins W350 4wd P/U, no electronics, old 70's style firewall mounted regulator, i'll get to the bottom of it, just the bullcrap of junk 150.00 alternators drives me NUTS!! and not to mention the labor that who's gonna pay? for all the R&R times.:crazy:

  • glh85

Posted June 05, 2009 - 07:50 AM

#8

You should be able to full field the alt because you have the external regulator. thats the best way to check that alt. it checks all the wiring in the tuck and it checks the alt at the same time.
mark

  • aakmetz

Posted June 05, 2009 - 08:27 AM

#9

You should be able to full field the alt because you have the external regulator. thats the best way to check that alt. it checks all the wiring in the tuck and it checks the alt at the same time.
mark

thanks, but they have a full bench tester at the napa store and they've been testing them, as i take them off.

  • glh85

Posted June 05, 2009 - 08:34 AM

#10

I had this on my old power wagon, basically uses the same charging system. I retured like three alt and two regulators. I found that I had a no ignition hot to the feilds, so I had no charging. then I tried to full feild the alt on the truck and was able to find the bad wire. Are the alts checking out bad at napa? Is this the nippindenso alt?
Mark

  • aakmetz

Posted June 05, 2009 - 09:05 AM

#11

I had this on my old power wagon, basically uses the same charging system. I retured like three alt and two regulators. I found that I had a no ignition hot to the feilds, so I had no charging. then I tried to full feild the alt on the truck and was able to find the bad wire. Are the alts checking out bad at napa? Is this the nippindenso alt?
Mark

it has all proper ign feeds at the reg and alt, yes they all tested bad, even took one to another store w/ a different tester, they are just bad parts. hopefully i'll get a good one sooner or later.

yes, i believe its a nip. alt.

  • toyota_mdt_tech

Posted June 05, 2009 - 10:06 AM

#12

pulling my hair out, i'm a mech for 30yrs now, customer's truck not charging, all wiring and such in spec. 2 reman alternators, 2 new alternators, from napa, no charge condition, bench test them, all bad............ anyone else in the business ever experience such stuff. has QC gotten this bad? all made in mexico. nothing against them but i'm at wits end.:crazy:


What is the pin ID? I'd bet you didnt get 4 bad alternators. I suspect the problem is with the truck, and the tech bench testing the alternator isnt hooking it up correctly. No open fuseable links? If there is an open, voltage from the alt with no where to go can spike way up, this may be the scenario and a sensitive voltage regulator is being taken out. A pin out of the alt, and even better yet, a wiring diagram. I will check alldata and see if I can spot something.

OK, looked at the EWD, this feild circuit is an "A" type meaning the feild is grounded by the regulator. Make surte the regulator body is well grounded. And make sure one side of the field has power. Then you could ground the lead going to the regulator to "full field it to check the alternator and other circuits. If it works then, this will lead you to the field circuit and regulator itself.

  • toyota_mdt_tech

Posted June 05, 2009 - 10:21 AM

#13

thanks, but they have a full bench tester at the napa store and they've been testing them, as i take them off.


I'd bet they are putting 12 volts to the "F" terminal to full felid it, when it requires a ground to full feild it. There test bench will usually have a switch for field, it will read "A circuit" and a "B circuit", 90% of everything is a B type, but not this one. Unplug tyhe reulator on the rig, key on, one pin will have 12 volts, other will be from alternator. The pin that doeasnt have the 12 volts is the one you ground.

Oh, for those other Chrysler where the regulator is part of the ECM, ran into this with a Lebaron, I just installed a Chrysler external regulator just like the one you have on your Dodge. Fix and didnty have to replace the ECU. Anyway, I have a simple diagram I copied from an unamed source :crazy: and will post it if you need it.

I'm an auto tech of 30+ year, 5 yrs of it was rebuilding alternators for a large HD rebuilder and a Ham radio operator, this is my area of expertise. :eek:

PM me if you need a simple wiring diagram of the charging system.

  • glh85

Posted June 05, 2009 - 10:58 AM

#14

the nipendenso alt, from what Ive heard is that they are indestuctable, but I see all the broken ones. Its such a rariaty that these alts go out that autozone doesn't carry them. I had a bad one on my cummins. it was a 92 and had the pcm controlled regulator that I bypassed to a fender wall mount. It DOES sound like you are getting bad alternators from napa, and that you have everything checked out under the hood. My only other suggestion is to go to an alternator rebuild shop and have them rebuild your old one.
Mark

  • aakmetz

Posted June 05, 2009 - 06:37 PM

#15

I'd bet they are putting 12 volts to the "F" terminal to full felid it, when it requires a ground to full feild it. There test bench will usually have a switch for field, it will read "A circuit" and a "B circuit", 90% of everything is a B type, but not this one. Unplug tyhe reulator on the rig, key on, one pin will have 12 volts, other will be from alternator. The pin that doeasnt have the 12 volts is the one you ground.

Oh, for those other Chrysler where the regulator is part of the ECM, ran into this with a Lebaron, I just installed a Chrysler external regulator just like the one you have on your Dodge. Fix and didnty have to replace the ECU. Anyway, I have a simple diagram I copied from an unamed source :crazy: and will post it if you need it.

I'm an auto tech of 30+ year, 5 yrs of it was rebuilding alternators for a large HD rebuilder and a Ham radio operator, this is my area of expertise. :eek:

PM me if you need a simple wiring diagram of the charging system.

thanks man, i have a manual that has a diagram. my ign voltages are right, so are the grounds, i had the alternators tested on 2 different testers, the test set up at advance auto and napa are very idiot proof, so hook up was near impossible to mess up, i watched and coached each time, and they failed. i'll find one that works, they got a 4th one for me. odds are it should work, my thought is the year of the alt application is only 90 to 93 and not a high inventory mover, for the area, so this batch wasn't tested or done properly, we have a major napa warehouse here so its stock stuff from their shelves, some of the boxes were very dusty, its the only theroy that makes sense. also the store owner, ( know for 20yrs) said they had a rash of bad reman stuff, so they switched suppliers.

  • aakmetz

Posted June 05, 2009 - 06:39 PM

#16

the nipendenso alt, from what Ive heard is that they are indestuctable, but I see all the broken ones. Its such a rariaty that these alts go out that autozone doesn't carry them. I had a bad one on my cummins. it was a 92 and had the pcm controlled regulator that I bypassed to a fender wall mount. It DOES sound like you are getting bad alternators from napa, and that you have everything checked out under the hood. My only other suggestion is to go to an alternator rebuild shop and have them rebuild your old one.
Mark

old one went to the core barrel, to be glass beaded, decaled, not tested, and reboxed to drive me CRAZY:lol:

  • Chickenhauler

Posted June 06, 2009 - 11:28 AM

#17

pulling my hair out, i'm a mech for 30yrs now, customer's truck not charging, all wiring and such in spec. 2 reman alternators, 2 new alternators, from napa, no charge condition, bench test them, all bad............ anyone else in the business ever experience such stuff. has QC gotten this bad? all made in mexico. nothing against them but i'm at wits end.:thumbsup:


I didn't think the '90 was electronic; I know Crysler in their infinite wisdom likes to put the voltage regulator in the ECM itself. I've seen many failures; customers love the expense of replacing the ECM for a simple voltage regulator failure.

If you replace the alternator with an internal regulator model it works, but you wind up with an eternal check engine light.


My alt/starter rebuild shop warned me about these this winter-they alt will bench test just fine, but when installed in the vehicle, will not charge. There is a circuit board inside the alt that isn't functioning properly, and unless you know how to test them, you're SOL.

I'll ask him tomorrow at church...I had too many beers in my blood stream when he was telling me about why lost so much hair in one week.

  • aakmetz

Posted June 06, 2009 - 07:31 PM

#18

My alt/starter rebuild shop warned me about these this winter-they alt will bench test just fine, but when installed in the vehicle, will not charge. There is a circuit board inside the alt that isn't functioning properly, and unless you know how to test them, you're SOL.

I'll ask him tomorrow at church...I had too many beers in my blood stream when he was telling me about why lost so much hair in one week.

lost hair doesn't turn gray,its one of those things to be thankfull of.:thumbsup:

  • chris142

Posted June 07, 2009 - 01:28 PM

#19

Have you had the new alts tested before you put it on the truck? Might save some hair that way.

  • aakmetz

Posted June 07, 2009 - 02:28 PM

#20

Have you had the new alts tested before you put it on the truck? Might save some hair that way.

yes, i have they spiked up to 23 volts, we are gonna reveiw our testing tommorow, w/ the one on now, and the new one out of the box, we will make this truck charge one way or another.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.