99WR400 OIL FILTER FULL OF METAL



3 replies to this topic
  • SALTY

Posted August 27, 2002 - 06:45 AM

#1

CHANGED THE OIL ON THE BIKE THIS MORNING. WHEN I TOOK THE FILTER OUT IT WAS FULL OF METAL PARTICLES. I KNOW SOME METAL IS NORMAL, BUT THERE WAS HEAPS OF IT. THE OIL WAS ALSO A SILVERY COLOUR. THE BIKE IS RUNNING FINE. ANYBODY GOT ANY SUGGESTIONS?

  • PumpkinHumper

Posted August 27, 2002 - 06:49 AM

#2

clutch maybe?? the metal plates take alot of abuse.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Taffy

Posted August 27, 2002 - 07:45 AM

#3

something has been chewed up inside. it may not be the end of the world and after all these bikes have good filtration systems nowadays.

first of all use a magnet to see if it's metal or alloy. if it's alloy your better off.

you can take the rocker cover off and have a ganders in there and also take the clutch cover off and have a butchers in there as well.

after that i suggest you pray.

Taffy

  • SALTY

Posted August 27, 2002 - 07:51 AM

#4

BAD NEWS. ITS MAGNETIC. HAD THE ROCKER COVER OFF, LOOKS FINE, SAME WITH THE CLUTCH COVER.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.