Brake light pressure switch?????? 2003 wr450


3 replies to this topic
  • warden415

Posted March 24, 2009 - 05:32 PM

#1

I bought a used 03 wr450. The guy said the pressure switch on the rear brake went bad so he put a new one on. It also quit working very quickly. I just bought a new one and installed it about a month ago. It was working fine. I took the bike out tonight for the first ride of the year and when I got home I noticed it isn't working again! Is there something simple I should look for that may be causing this or do you think I am just having bad luck with the switches? I thought maybe there was something specific to wr's that I should look for the root of the problem. Thanks for any suggestions, Steve

  • Krannie McKranface

Posted March 24, 2009 - 05:44 PM

#2

You just need to put in a quality unit, like the one from Baja Designs. The 'off-brand' ones I have tried from Cycle Gear, Dual Sport America, and Bike Bandit have all failed in a few months.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Desracer

Posted March 24, 2009 - 08:31 PM

#3

I have bought one from several places, the BAJA stuff is good and still works in my old 03 which my son owns. Then again I have friends that melted the wires off on the pipe in a few days also.

  • bluebreadtruck

Posted March 25, 2009 - 03:52 PM

#4

some of the new baja designs come with a 90 deg end also, so that is nice (at least the front brake switch)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.