HELP 05 YZ450 not wanting to idle (grayracer)


2 replies to this topic
  • Jake92

Posted March 23, 2009 - 12:58 PM

#1

Was fine in the fall but now the bike doesnt want to idle. Ive got a 13.5:1 Wiseco in it which I like but hate the slap noise. It idles very rough and will usually die if let idle from the roughness.(like a roller cam V8) Is 20 hours too long for this piston/rings? Is this what my bad idling is from? Compression doesnt feel excellent but doesnt feel bad either. 170 hours on Bottom End.(never split)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted March 23, 2009 - 01:07 PM

#2

If you are running pump gas, this is about the time of year that the blenders shift from their winter blend to the summer stuff. It can change the jetting requirements. Try adjusting the idle fuel mixture.

When you say it was fine in the fall, that suggests the bike sat all winter. Try it with fresh gas, and add the prescribed amount of fuel system cleaner to the fuel. If it doesn't straighten out on its own, you'll have to clean out the carb.

  • 642MX

Posted March 23, 2009 - 03:35 PM

#3

Being its a steel frame bike (which allows easy carb access), I would tilt the carb sideways, remove the 17mm nut and pull the pilot jet and spray some carb cleaner/compressed air thru it. I bet its restricted.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.