Scotts Submount cable routing


4 replies to this topic
  • JWW

Posted March 17, 2009 - 07:44 PM

#1

Installing a Scotts submount. Stock the throttle, clutch & hot start run between the odo mount brackets. Clutch and hot start seem fine but the throttle cables are pretty tight. It looks like I can move them to the outside of the odo bracket. Anybody try this?

I did a search and all pics look like the cable is routed as stock. Do you throttle cables feel tight when full lock left?

  • JWW

Posted March 17, 2009 - 08:06 PM

#2

Pics dont really show the issue but they come up from the right side, left through the odo brack and then right back to the throttle.

Posted Image

Posted Image

Posted Image

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • bg10459

Posted March 17, 2009 - 10:13 PM

#3

I ordered +2" throttle cables from Motion Pro when I added a Submount.

  • JWW

Posted March 18, 2009 - 08:23 PM

#4

I ordered +2" throttle cables from Motion Pro when I added a Submount.


Thanks- Going to order tonight. I can only find +1" on the Motion Pro site but that shoud be good.

  • bg10459

Posted March 19, 2009 - 04:05 AM

#5

Thanks- Going to order tonight. I can only find +1" on the Motion Pro site but that shoud be good.

The cables will be custom, either way, so order what you think you'll need.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.