1999 WR 400 Compression Release Oil Leak

3 replies to this topic
  • alindbla

Posted March 02, 2009 - 08:05 PM


I just bought a 1999 wr 400 and I noticed that the compression release is leaking a little bit of oil. It leaks while I am riding, not just when I use it. This is the first bike I have owned and am not quite sure what to do. I would appreciate any ideas and suggestions anyone would have.



  • matt4x4

Posted March 03, 2009 - 05:16 AM


Replace part #15 - it's a 10 minute $5 fix.
Posted Image
Just make sure it's leaking there and not on bolt #13 - if it';s leaking on bolt #13, replace washer #14

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • alindbla

Posted March 03, 2009 - 02:42 PM


Thanks, I will replace that part and see if it stops the leak.

  • maxtherat

Posted March 03, 2009 - 06:18 PM


Be cafeful when you tighten screw #13. It can strip very easily. A little suggestion, after lever is removed, use an allen wrench to push out the seal from the inside out by putting the short angled end of the allen through the hole for bolt #13. There is a small tensioning spring inside the lip of the seal that could possibly popout into the motor while trying to remove the seal.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.