01 yz426 radiator problem.

8 replies to this topic
  • banshee91

Posted February 22, 2009 - 12:43 PM


I was out riding some trails on my bike today... got into a real messy trail where the wheels were spinnin a LOT, all of a sudden there was steam shooting out of my right hand radiator :lol: . i filled it back up with coolant and started the bike and let it warm up, i couldnt find any leaks. just wondering if theres some sort of pressure release system on the bikes. anyone had the same thing happen to them?

  • MuDPoUNdeR

Posted February 22, 2009 - 12:50 PM


Did you fill your radiator with the right mixture of coolant? Or does it come premixed?

  • banshee91

Posted February 22, 2009 - 03:30 PM


umm i usually mix it.. it was premixed this time, do you have any idea what it mite be? i cant figure it out theres no sign of any leaks

  • TIG88

Posted February 22, 2009 - 04:29 PM


Out of the radiator cap? If so you overheated it.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Ztard

Posted February 22, 2009 - 05:35 PM


I had my cap go bad after a few repeated muddy days...ie the bike got hot more than a few times. replaced the 1.1 cap with an Outlaw racing 1.6. Kawi sell the same cap for less

  • banshee91

Posted February 23, 2009 - 02:17 AM


yeh i think it was from the cap.. so i just need to buy a new one is it?

  • matt4x4

Posted February 23, 2009 - 04:42 AM


You may not need a new one - they are designed to let go if the pressure gets too great - saves your head/base gaskets. I would pressure test it to make sure it's still ok.

  • rufusz

Posted February 23, 2009 - 06:30 AM


I use my 426 for enduro/woods riding, it often shoots steam out of the right hand radiator. It's just normal overheating, let it cool down, and check coolant more often. If you overheat it many times during a trip, fill radiator with water (from rivers, camelback, anything you'll find), just make sure to change it when you're home

  • TheLuckmeister

Posted February 23, 2009 - 06:52 AM


Same thing with me, just replaced my cap.

Related Content


Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F

Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.