not sure what tank i have now

11 replies to this topic
  • waterman7474

Posted February 18, 2009 - 08:48 AM


i thought it was a clarke 3.6 but i bought a new cap that is supposed to be fore a clarke but it won't seal and now after reading for a while, i'm not sure...

Posted Image

  • trailhead2004

Posted February 18, 2009 - 02:30 PM


Hey Waterman,

It looks like a IMS from the shot you posted. The reason I say that is because the top of the tank where the cap is doesn't look tall enough for the Clarke (I have the Clarke). I have seem both right next to each other and to me your's looks like the IMS.

That's the best I can tell you for now, if I can locate my pics of the tanks maybe I can give you a definite answer.

Another idea is to look in the WR forum for threads on gas tanks and see if someone has a similar picture with the tank identified by brand. The thing I'm thinking about is looking at the section of tank below the rad shroud.

Good Luck!!!


  • ranger85

Posted February 18, 2009 - 02:58 PM


Well thought it was Acerbis, but I found a IMS pic that looks just like it.


  • DrzDasher

Posted February 18, 2009 - 08:33 PM


IMS, one way to tell to is from the left side, looks like the ims 3.1 to me though.

  • squid

Posted February 18, 2009 - 08:39 PM


IMS i have the same tank

  • waterman7474

Posted February 19, 2009 - 07:34 AM


nice...i knew something was wrong.

thanks a lot yall!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • WReckless

Posted February 19, 2009 - 12:49 PM


my ims on my 2000 looks different. it could be a different model or the fact that we poured boiling water in it and put the cap on before we installed could change the look.

  • hillclimbguy

Posted February 19, 2009 - 11:15 PM


Looks like the same tank I have. And its an IMS.

  • jerejuly

Posted February 20, 2009 - 07:11 PM


Well that answers my question concerning my tank. They are identical.
What is the fuel capacity? From what I've read it is only 3.1 gallons.
Is that right? It just looks like it should hold a lot more.
Just bought an 03 and the previous owner wasn't sure either.

  • waterman7474

Posted June 17, 2009 - 07:34 AM



K, so originally I thought it was a clarke tank and bought a cap from a shop, screwed on fine but didn't seal, no mater how hard i screwed it down (much leakage). So I started this post yall all think it's an IMS. I look on their website but the only pics of caps look just like the last one I bought for a clarke. So I buy another one from a shop that oddly looks exactly like the clarke one but slightly different packaging and sure enough....has the exact same problem, screws on fine but doesn't seal.

So I look on thumpertalk's parts page and the pic of the cap available in the tucker catalog for a standard replacement (not billet or anything) looks just like the one that I originally had that broke. So I order it and when it shows up, it is the exact one that I just bought last week (which doesn't work...) and not the one in the picture. So while i'm there picking it up and trying to figure out what the problem is, we call IMS they tell us that while the cap did change, they are quite sure the threads didn't, only the outer part.

So I went back to it last night and double and triple checked to make sure i was getting the rubber insert part in correctly.....tried it super tight, kinda loose, the top isn't warped, threads aren't messed up.....and still won't seal. (to be clear, this isn't a breather hose problem, this is letting lots of fuel out between the tank and the cap).

All I know is that the last cap I had looked EXACTLY like the one in the catalog pic. One thing of note, the threads on this new cap go all the way down inside to the flat sealing face. Meaning, that on this newer one, as the rubber insert is screwed in, one side makes it down to the end of the thread while part of it is still in the thread and not all the way down to the flat surface.

On the old one I had, I could swear that there was a space between the flat sealing face and the termination of the thread and once the rubber insert was screwed all the way into the cap, it was held in kind of loose and and allowed to sit flush against the top of the cap.

I the only markings on the tank are on the top, between the seat post/hook/attachement and the screw for the hold down strap. The only thing is says is "yz # 17"

I've sent IMS an email recapping most of this to see if is in fact one of theirs but they haven't responded.


  • waterman7474

Posted June 17, 2009 - 09:34 AM


ok, scratch all that. i was able to talk with someone at IMS and it looks like it is one of theirs but it is a much older style. they were able to find an old cap and are sending it to me.

if this doesn't work, looks like a new tank...

  • neanderthaler

Posted June 26, 2009 - 07:51 AM


what happened? did you get the cap and does it work? i just ordered a tank for the same exact problem (with my stocker on a wr250f). actually i ordered both the ims and the clarke to see which is gonna work and fit better. i have two concerns 1) i have moose/enduro eng. rad guards 2) i have a megabomb that might sit too close to the tank.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.