WR brake light

2 replies to this topic
  • slider91129

Posted December 31, 2008 - 03:43 PM


Ok, I finally got my lighting problem resolved. Stupid mistake on my part... Now, I'm trying to hook up a rear brake light. I have a switch in the rear master cylinder that works. I have a cheap fiber optic taillight from DRC that works on a running light. When I splice into both the blue and/or yellow behind the connector under the tank, I get nothing when the brakes are applied. If it helps, the taillight has black (grd), red and yellow wires. Any help would be appreciated. I've wired several XR 600s with no problem. Thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 1rkcooper

Posted December 31, 2008 - 07:40 PM


Not sure what bike you're working on but I think you should only have to splice into one wire not two. The wire you splice needs to have power. Put your brake switch in the middle of the splice.
Do a search, wiring brake lights has been discussed a couple of times recently.

  • slider91129

Posted January 01, 2009 - 07:05 AM


Oh sorry its a WR426 but thanks for the info!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.