Two 05's, Two different bikes


3 replies to this topic
  • c9buff

Posted December 29, 2008 - 08:27 PM

#1

Me and a riding buddy have 2005 WR 450s. My bike's engine response is very quick causing a great deal of wheel spin, almost making it unrideable up hills. As soon as I get on his and let the clutch out I notice a big difference. His has half the response as mine but his low end torque and hookup are fantastic.

I can ride his bike up any hill while I have problems with mine. In a nutshell, my bike rides like a YZ and his is a John Deere.

The only difference in the two bikes is an aftermarket slip on exhaust. He has a Pro Circuit 296.

Could this really make that low end difference or do you think he may have a flywheel weight installed. Any input appreciated.

buff

  • brad the best

Posted December 29, 2008 - 08:40 PM

#2

do you both have all the free mods done ?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • c9buff

Posted December 29, 2008 - 08:44 PM

#3

As far as I know we do.

  • bluebreadtruck

Posted December 29, 2008 - 09:01 PM

#4

possibly one has different yz or aftermarket cams (yours)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.