new rebuild, coolant leak, can't figure it out

1 reply to this topic
  • HartsYZ450

Posted December 28, 2008 - 11:27 AM


this is an 03, 450. just rebuilt it from the crankshaft up. it runs ok, untill it warms up, then coolant starts leaking out the weephole below the waterpump. put new seals in , and the shaft is realatively new. flow passage seem clear when blowing through all waterjackets, and radiators.
what am i missing?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • qwik12beat

Posted December 28, 2008 - 12:00 PM


Replace the inner/outer seals,impeller shaft, and the bearing. Your bearing is probably ol and worn letting the shaft move around, and destroying your seals. Just had the same problem:thumbsup:

Related Content

WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.