08 YZ450 jetting after pipe insallation

9 replies to this topic
  • JDLowrance

Posted December 25, 2008 - 08:59 AM


Hey guys,

Having issues with SEVERE hesitation comming off 1/4 throttle to 3/4 or wide open throttle to clear obstacles (whoops, jumps out of corners, etc.). The bike acts as if it wants to die then rockets forward (the dreaded cough but no stall...at least not very often). It gets worse with elevation (from 3000ft to 6000ft). First noticed it at Milestone MX track which is about 1500ft (I think).

Bike is an 08 with 12 hours. I installed a Dr.D pipe with spark arrester and 96dB insert to keep the noise down. Stock jetting (as I'm sure you know) is M160, 3rd clip, 42 pilot. Dr.D's recommended jetting is M 165, 4th clip, stock pilot. Initially tried this setting and had the symptoms listed above. I imediately thought it was rich because of it getting worse with elevation so I started leaning it out...neddle back to stock, down to 162 main, 160 main, Boysene quick shot, etc. Tried several variations with jetting and it didn't seem to resolve the issue. Just made the power in the midrange and on top weaker or stronger without fixing the problem. Didn't change the pilot as by all accounts not the issue.

So, now I'm thinking accelerator pump/leak jet. Could it be that the stock pipe (being so restrictive) needs a larger leak jet (leaner) than a better flowing system would require? Checked the squirt and it's strong and timed right.

So after that long winded post the real question is you guys that mounted up aftermarket exhausts to your 08 YZ, did you have a similar issue and if so how did you resolve it?

I live in SoCal and am in the process of converting the bike over to Supermoto so the elevation won't be changing as much. Should be right around 1500ft to 2500ft for most if not all of my riding/racing.

Thanks in advance for any help.


  • JYZ566

Posted December 25, 2008 - 10:44 AM


On my bike (08 YZ450f) with a Pro Circuit Pipe, I reverted to the stock 06 jetting specs (needle and all) and put a boyeseen quickshot 2 on. No bog, no hesitation....just smooth power baby. IMO, the 08's are very lean from the factory....

  • JDLowrance

Posted December 25, 2008 - 11:53 AM


What are the 06 jetting specs that you used?

thanks, John

  • grayracer513

Posted December 25, 2008 - 12:29 PM


Read through this, particularly the first post by todds924.


Also, read through some of the other links under Fuel Systems in the Common Threads sticky.

  • xorron5

Posted December 26, 2008 - 07:45 AM


-09 YZ450F i put dmc aft.burn comp. no problems only thing what i changed
is the main to 165 ,and i am using r&d powerbowl ZERO BOG and u can wack the throttle as fast as u want and it responds...i know there are people who
questions the powerbowl but 0 problems is good value..:busted:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JDLowrance

Posted December 26, 2008 - 09:00 AM


Read through this, particularly the first post by todds924.


No link for todds924. Please resend.

Thanks, John

  • grayracer513

Posted December 26, 2008 - 09:47 AM



No link for todds924. Please resend.

Thanks, John

Oops. See what can happen?

Anyway, I fixed it. It's the first post in the jetting thread for the '08's which you can find through the main jetting sticky or Common Threads.

  • yz007f

Posted December 26, 2008 - 11:05 AM


Really that bike should run with the stock jetting.. Other than some lean poping. I might base line your jetting right back to stock and take the boysene quick shot out.. I good test would be to try and ride the bike around at half choke. If the problem is worse then you know where to go.. You did not talk about the fuel screw at all. I have seen this before when the fuel screw is lean the bike will do the same symptoms you listed. I would base line it and then go back to what dr.d said and richen up your fuel screw that should fix it. I have a 09' 450 with the full dr. d system and running indoor at around 50 deg needle in 4th clip 170-175 main and the fuel screw is rich. I can't remember what I have it set at but that thing is lighting on the response.

  • Family Man

Posted December 26, 2008 - 12:34 PM


yeah try adjustting your pilot circuit first it a stickie at the top of the jetting forum.
From what Ive read on the 08-09 bike raise the needle and put in a 165 main and that should put you in the ballpark with an aftermaket exhaust.

  • Family Man

Posted December 26, 2008 - 12:35 PM


Raise the needle on postion at a time.

Related Content


First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.