Hebo juice clutch failures



2 replies to this topic
  • YZ400Court

Posted July 08, 2002 - 06:19 PM

#1

Has anyone had problems with the Hebo Juice clutch? I remember Dan Lorenze did in the Nevada 1000. Just wondering what common problems I may face with it.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Dan_Lorenze

Posted July 08, 2002 - 06:28 PM

#2

Court, The problem I had with my clutch was that the o-rings would go out and then the thing would leak. Also, the way that the clamping nut would go on to the cable would either fray (s?) or slip off. When I first got it I loved it!! It's just one of those things that are really nice to have but it comes with a price, I seriously rode at least 200 miles with no clutch that race and vowed never to put it back on. I hope you have better luck than I did. Good luck!!!

Dan

  • SFO

Posted July 09, 2002 - 05:34 AM

#3

Riding 1000 miles straight has a tendency to accelerate any issues that a trail racer might never uncover.
1400 miles of baja pretty much ate my bikes lunch too.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.