02 yz426 misfire and backfire

1 reply to this topic
  • falcodm1

Posted December 02, 2008 - 01:02 PM


I have an 02 yz426. midway through the riding day it starts missing and backfiring at all throttle possitions. Suspecting a cloged jet, I dissasembled and cleaned the carb, changed the fuel in the tank and cleaned the spark plug and still had the same problem. At this point I'm thinking possible ignition problems. I've heard of computer failures causing the same conditions. A this point I'm looking for any ideas.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted December 02, 2008 - 02:09 PM


Sounds electrical to me. It's going to be tough to pin down.

Related Content


Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.