What is this??


6 replies to this topic
  • Ridon

Posted November 14, 2008 - 08:47 AM

#1

Ok, i have a WR450F 04. The bike runs perfectly, i've done the free mods and i had no problems either so far. Yesterday i noticed something strange, when i'm in third gear and i give full throttle the bike revs more as it should but accelerates after a while not instantly. What is this?

  • doctorchopper

Posted November 14, 2008 - 09:17 AM

#2

sounds like your clutch is slipping

  • matt4x4

Posted November 14, 2008 - 11:54 AM

#3

clutch slipping - agree ^^^

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • clark4131

Posted November 14, 2008 - 12:24 PM

#4

Time for some new fibers and steels...Do I hear Rekluse maybe?...SC

  • SJMC_DON

Posted November 14, 2008 - 01:53 PM

#5

like the other guys say... clutch slipping.

I recommend OEM fibers and plates... I've tried DP and barnett I think. Anyway, the OEM fibers are cheaper and last longer imo.

Good luck:ride:

  • tcmII

Posted November 15, 2008 - 04:23 PM

#6

You've just learned one of the time honored methods for testing clutch slip.

Get the car/bike rolling in 1st/2nd and then shift into a high gear 4th or 5th, then accelerate hard. If the engine lugs your good. If you get a quick increase in engine RPM, the clutch is slipping.

  • Ridon

Posted November 18, 2008 - 01:22 AM

#7

Thank you guys, you were right as always. I changed the plates anf fibers and the bike is like new. It's the first time i changed them.:thumbsup:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.