06 yz450 backfire

No replies to this topic
  • J-dub123

Posted November 08, 2008 - 10:09 AM


my 06 Yz450 wont idle down unless I clutch it. It backfires on decel like a machine gun. The valves are within spec. Has a 4% leakdown. 45pj/165 main. The hot start is seating fully. It's not leaking at the carb mount. The exhaust dont have any leaks. It ran fine and I took it out to ride one time and it was doin this crap. I cleaned out the carb and it didnt help. Turnin the fuel screw does'nt help at all. I checked the entire electrical system and everything checks out fine unless it's intermittent. I dont know what else to check?

Related Content


First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.