Smoking starter switch


5 replies to this topic
  • Fullbore4

Posted October 24, 2008 - 09:06 PM

#1

Went to start my bike and turned it over with electric starter for a good 30-40 seconds......it finally started but smoke came up from the power on button near the speedometer...what is that from? 06 WR450

  • Fullbore4

Posted October 28, 2008 - 01:00 PM

#2

After this I'll kick start if electric start doesn't do the trick in 15 seconds.....Anyone seen smoke?

  • godhappan

Posted October 28, 2008 - 01:06 PM

#3

out of the speedo "on" button ?

or the elec start button?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Fullbore4

Posted October 28, 2008 - 01:16 PM

#4

From the "speedo on" button or "Main switch" button right next to the speedometer.

  • godhappan

Posted October 28, 2008 - 02:08 PM

#5

not good does it still work? have you washed the bike recently? (was it wet)
or really dusty/dirty?

  • Charles De Mar

Posted October 29, 2008 - 09:02 AM

#6

No I have never seen smoke. i did accidentally pull the wires out of the starter button with a tie down recently.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.