450 been setting without water

2 replies to this topic
  • btray

Posted October 20, 2008 - 03:30 AM


A friend of mine purchased an 03 450 and had been setting torn down for kick idle gear replacement. Someone told him to check some seal in the cooling system that can go bad after a time when setting up. Does anybody know what the guy may be talking about? The only thing I could think of is the water pump...but I've never let mine set up so havent had this problem.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted October 20, 2008 - 06:08 AM


Has to be the coolant seal on the impeller shaft. It won't hurt to replace it, and it could be quite annoying if you don't.

  • btray

Posted October 21, 2008 - 05:05 AM


Thanks gray...think I'll pick one up

Related Content


YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.