Broke my E-Series

2 replies to this topic
  • JT1

Posted June 17, 2002 - 07:12 PM


I'm not exactly sure how it happened but I think it was from casing a double. The 2" pipe that is welded to the larger 5" canister broke in a complete circle. The clamp that is towards the engine may have vibrated loose making the bolt a pivot area and the impact of the jump may have caused stress on the least that is what i'm telling myself .

anyone experience anything like this?

Has anyone put a spark arrester on their stock pipe (promoto billit)? was it easy to do?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JaZ

Posted June 17, 2002 - 11:33 PM


I had the same problem but had about 15mm left on when I noticed it.
Just took muffler to a aluminium welder and he not only fixed it but beefed it up as well, as this is a weak point, cost me $25 AUS
Also had a problem with the internal scread seperating from the flange as they are only tacked on, might pay to check them.

Good Luck

  • JT1

Posted June 18, 2002 - 04:23 AM


Jaz, what's a scread? thx, i'll call some local welders and see if they can fix it.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.