BK Carb Mod


10 replies to this topic
  • Thrasherg

Posted September 05, 2008 - 11:59 AM

#1

Gents,
I recently purchased a 2001 YZ426 and as everyone does, I looked at all the mods on Thumper Talk and started doing them:applause: . I have just performed the BK carb mod but am worried that I might have got it wrong. I followed the instructions about where to drill the hole and fit the bolt to limit the accelerator pump cam travel, that is all done correctly. :thumbsup:
As per the instructions, I wacked open the throttle from idle to WFO and timed the fuel pump spray. It came out at 7 seconds, according to the documentation on this mod they list the time as around 1.5 seconds :worthy: for a standard carb? Have I misunderstood what I am measuring? why is there such a big difference between my measured time and the stated spray times:confused: ?
I then adjusted my newly fitted bolt to get the spray time down to 0.3 seconds and ended up with the bolt almost touching the cam, but in all the photo's I see, there is a large gap between the end of the bolt and the cam (when the throttle is in it's idle position):busted: ..

I just want to know if I messed up somewhere, the bike still seems to run fine, but I have only ridden it up and down my drive as I am waiting for some other parts.:blah: Thought I would ask for feedback before I go and try it on the dirt..

Thanks Gary

  • BASSic

Posted September 05, 2008 - 02:05 PM

#2

With the screw backed out some, does the cam move quickly when you twist the throttle, or is there a big delay? Even after installing a heavy O-ring, the cam didn't move quickly and in fact the O-ring was stretching far.

I found that my accelerator pump linkage was gummed up and not moving quickly; because it was so slow the duration of the squirt was very long however the squirt didn't go very far. Once I cleaned the linkage up, the cam moved fast and I got a long rapid squirt of fuel.

  • Thrasherg

Posted September 05, 2008 - 07:41 PM

#3

The cam does not seem to move very fast, but I have a jet of fuel that must be 4 0r 5 inches long coming out of the accelerator nozzle, it squirts clean out of the carb. I have not fitted an o-ring to the throttle linkage. The linkage did seem to move fairly freely by itself. What sort of gap do people that have made this mod have between the cam and the bolt?

  • Thrasherg

Posted September 09, 2008 - 07:10 PM

#4

Can no-one offer any advice? I think I will remove the cam stopper screw until I can get some help as the gap between the cam and the screw looks too small to be realistic. I will open the carb this weekend and check all the pump linkages are moving freely.

Failing that is there anyone I can send the carb to and have these modifications made?

Cheers

  • grayracer513

Posted September 09, 2008 - 08:42 PM

#5

Try your post in the jetting forum.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Thrasherg

Posted September 10, 2008 - 05:14 AM

#6

I thought the BK mod was bike specific? I will try it in the jet section, thanks for the sugestion.

  • grayracer513

Posted September 10, 2008 - 06:14 AM

#7

It is bike specific, but there may be a carb guru in that forum who has done enough of them to know more about it.

  • anaconda

Posted December 03, 2008 - 10:56 PM

#8

Hey guys. New to this forum. I like it. I also have a 2000 YZ426F and wanto to do the Carb Mod. Where can I get the instructions? I hope they come with pics. hahaha

  • 426 NOOB

Posted December 03, 2008 - 11:12 PM

#9

Hey guys. New to this forum. I like it. I also have a 2000 YZ426F and wanto to do the Carb Mod. Where can I get the instructions? I hope they come with pics. hahaha


The BK Mod (accelerator pump mod for YZ426)
http://motoman393.th.../tech/carb.html

  • grayracer513

Posted December 04, 2008 - 07:16 AM

#10

Where can I get the instructions?

I know I'm a smart ass, and I do apologize, but there's a reason the Common Threads sticky at the top of this forum's index says, "Look here first". :thumbsup:

  • 426 NOOB

Posted December 04, 2008 - 10:19 AM

#11

I know I'm a smart ass, and I do apologize, but there's a reason the Common Threads sticky at the top of this forum's index says, "Look here first". :thumbsup:


haha..





Related Content

Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.