Problem with Triple Clamp/Stabalizer

3 replies to this topic
  • Mrmonk7663

Posted August 05, 2008 - 06:19 PM


Hello. I tried to bolt up a GPR Stabalizer today on my bike but ran into some problems. The guy I bought the thing from told me it would mount to any fat bar triple clamp...this isn't the case evidently. I have a Longhorn Triple Clamp. Evidently the Longhorn piece puts the bar mounts at a closer distance than the stock triple clamp. Also the Longhorn piece has the bar clamps drilled at an angle vs. the stock clamps which are straight. Anyone ran into this issue before and if so how did you rectify it? It looks like im in some trouble here.


  • xrmarty

Posted August 05, 2008 - 09:55 PM


I had a similar problem on a Emig Racing triple clamp on my XR400. I ended up modifying the bracket that mounts to the frame, but I was never happy.

Unfortunatly, each installation kit is different depending on a type of bike and triple clamps used.

I lifted this directly from the Scott's website:

"This kit is specific to each bike with consideration for which combination of bars and triple clamps are being used."

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Mrmonk7663

Posted August 06, 2008 - 05:44 AM


Thanks man. I appreciate the response.


Posted August 06, 2008 - 05:56 AM


Make sure that the pivot point of the dampener is on center with the PP of the triple clamp otherwise it will bind up.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.