Antifreeze Question

2 replies to this topic
  • BlueDragon

Posted December 13, 2002 - 10:25 AM


I actually have 2 questions. Last week when I kicked over the beast I noticed a couple drops of antifreeze on the ground. I cleaned the spot, removed the guard covering the water pump and the next day kicked it again. This time a drop came out of a hole on the bottom of the water pump housing. Is this normal? Ive never noticed it before.
My bikes sit a week at a time without starting. Is there a way I can prime the cylinder walls with oil before starting to cut down friction and wear? Thank God for TT. Thanks Everyone :) :D :D

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Dodger

Posted December 13, 2002 - 10:55 AM


Sounds like your water pump seal may be going, the drips of AV weren't from the puke tube was it?? That's normal......

Don't worry about your bike sitting for a week or two at a time, shouldn't cause any problems. Last winter, my poor bike sat outside in the snow and cold for well over a month, never caused any problems when I went to fire her up again, just took a bit........

Dodger :) :D

  • BlueDragon

Posted December 13, 2002 - 01:09 PM


Wheres the puketube? Is it on the bottom of the water pump housing cover?


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.