Horn Help


13 replies to this topic
  • Mrmonk7663

Posted July 13, 2008 - 04:57 PM

#1

Well, I got my lights and my brake light all working great. Last night my horn was working somewhat...so I thought. Today I tried my horn and in order to hear it you have to put your ear up to the damn thing. I have my switch wire to the horn, a power wire to the horn, and the horn ground wire thats on the switch to a ground. It is wired correct I believe but no go. Like I said, when I push the button, it works, just not good enough to do anything. Last night it was alot better...wiring has stayed the same. Is there a way I can test the horn some how? I hooked up a postive wire from a 12v car battery and a negative wire from a 12v car battery and hooked it up to the horn and it didn't come on. I was under the impression that would make it run constant and at its full potential. Here is a link to my horn. Thanks.http://www.procycle....lsport/horn.jpg Oh, and its a 2 terminal.

  • Alternative

Posted July 13, 2008 - 05:45 PM

#2

Is there a way I can test the horn some how? I hooked up a postive wire from a 12v car battery and a negative wire from a 12v car battery and hooked it up to the horn and it didn't come on.


This should be a definitive test to see if the horn works, if done correctly. Did you remove the horn from the bike when you tested it? There could be an intermittent short in the wiring on the bike, take the horn off the bike a test it with the car battery, if no go then the horn is stuffed. If it works check all your wiring for shorts and if you've got a voltmeter, check you've got 12V at the horn terminals when the button is pressed.

  • Mrmonk7663

Posted July 13, 2008 - 07:03 PM

#3

The horn was 100% off the bike. It was just postivie and negative from good car battery hooked to the horn. I think the horn is toast. I'll give the company a call tomorrow. Thansk for verifying what I suspected.

MIke

  • maxtherat

Posted July 13, 2008 - 07:30 PM

#4

there should be an adjustment on the horn in the center of the back, I believe. Slightly turn that adjuster while appling power to the horn. If that does not do it then it may be shot. Does the horn specify ac or dc power?

  • maxtherat

Posted July 13, 2008 - 07:38 PM

#5

Oh yeah, is your ground wire attached the the horn itself or is it attached to the chasis? The ground should get connected to the horn directly.

  • Mrmonk7663

Posted July 13, 2008 - 08:43 PM

#6

The horn says it is for AC or DC, per the website that sells it. I have the horn wired so that one wire is from switch to horn, another wire is power to horn, and the final wire is switch ground wire to chasis. But I tested it off the bike hooked up to a car battery and got nothing. On the back there are 2 things. One is in the center and it has a slot for a screwdriver, this is also where the nut screws on to mount the horn to bracket. The other is a teeny tiny screw off center and I have no clue what the purpose of that is.

  • Mrmonk7663

Posted July 13, 2008 - 08:56 PM

#7

OK, i just turned everything that could be turned while the horn was hooked up to a car battery and nothing. I'm gonna assume its a goner. Thanks guys.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 2FlatsandBent

Posted July 14, 2008 - 12:13 PM

#8

That teeny tiny screw is what you need to ‘screw’ with. It’s a type of daiphram adjustment. If you can reach it while it’s still mounted to the bike then just turn it a little and test – turn a little and test. Try counter and clockwise. Once it’s at it’s loudest you’re done. Just be sure not to back it all the way out and loose it. Mine actually has a stop thread on it so it’s harder to turn at the end.

  • maxtherat

Posted July 14, 2008 - 06:22 PM

#9

The horn says it is for AC or DC, per the website that sells it. I have the horn wired so that one wire is from switch to horn, another wire is power to horn, and the final wire is switch ground wire to chasis. But I tested it off the bike hooked up to a car battery and got nothing. On the back there are 2 things. One is in the center and it has a slot for a screwdriver, this is also where the nut screws on to mount the horn to bracket. The other is a teeny tiny screw off center and I have no clue what the purpose of that is.


The description for your wiring sounds a little suspect to me. The way I am reading into your last post that there are 3 wires. It sounds like you may have hooked up two power wires to your horn and fried it. Looking at the wires from the link there should only be two wires; power from the switch and a ground from the switch to the horn, not the chasis. It's the same idea as the car battery one power source, one ground.

  • creeky

Posted July 14, 2008 - 06:31 PM

#10

The description for your wiring sounds a little suspect to me. The way I am reading into your last post that there are 3 wires. It sounds like you may have hooked up two power wires to your horn and fried it. Looking at the wires from the link there should only be two wires; power from the switch and a ground from the switch to the horn, not the chasis. It's the same idea as the car battery one power source, one ground.


This is my take also.

  • MicahRoss

Posted July 14, 2008 - 07:26 PM

#11

Yeah it should be......Power wire to the switch, then a wire from switch to the horn, and then horn to ground. That way when you hit the horn button it sends power through the switch to the horn.

  • ProCycle

Posted July 20, 2008 - 08:27 AM

#12

Yeah it should be......Power wire to the switch, then a wire from switch to the horn, and then horn to ground. That way when you hit the horn button it sends power through the switch to the horn.


Actually the horn button makes a ground connection (just like a kill button).
The correct wiring is -power to horn, -horn to switch, -switch to ground.

  • Mrmonk7663

Posted July 20, 2008 - 10:32 AM

#13

I ended up wiring my kill switch to my handlbar switch that controls my lights. I did this in place of the horn as the cheap horn I got with my kit was useless. I bought a mega horn electronic 105db horn and it runs off a 9v and its pretty damn loud. I can be in the garage and all inside the house can hear it. It will work niceley. I think its what Baja USED to use.

  • mrpbdy

Posted July 31, 2008 - 02:51 PM

#14

Maxtherat is right. The small screw on the back is a place to ground, but it also adjusts the diaphragm. I just wasted a day putting a horn on my wr450 to make it street legal. It worked, but it only made a clicking sound. After I saw Max's post I went back and messed with the screw and that did the trick. Turning the screw IN farther to allow for the ground wire was the answer




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.