YZ426F help pleaseeee


2 replies to this topic
  • BRY_426F_

Posted July 11, 2008 - 09:43 AM

#1

:thumbsup: :bonk: Okay well I have a 426 year 2000 and it pukes my coolant everytime i go out. It is leaking from the gasket on the waterpump/case cover area. it is also leaking from the little hole on the underside of my waterpump. I have even seen a few dribbles come out from a hole on the side of the head..:thumbsup: :thumbsup: IDK what it is... I have bought a replacement gasket but I'm not so sure water should be coming from my case in that area.. but then again I could be wrong.. That is why I am here. So any advice would be greatly appreciated1!!:thumbsup:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted July 11, 2008 - 09:52 AM

#2

The hole on the underside of the water pump is an escape port put there to allow oil or coolant leaks at the water pump impeller shaft to escape without cross contaminating the other fluid supply. It means the colant seal has failed, and the shaft may have a groove worn into it that will necessitate its replacement as well.

  • BRY_426F_

Posted July 12, 2008 - 10:11 AM

#3

SO YESTERDAY i MADE A TRIP TO MY LOCAL YAMAHA AND BOUGHT THE 2 SEALS THAT GO BEHIND THE IMPELLER hopefully this fixes the problem. and I plan on replacing the gasket between the case cover and right crank hopefully this fixes my problem. thank you for the info





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.