Runs Good!

2 replies to this topic
  • marcusmoberg

Posted June 27, 2008 - 09:47 PM


I changed the spark plug - cleaned the K & N air filter - changed the coolant & changed the oil & the K & N oil filter on my 400.

It runs fine now ever since I did all the maintenance on it.

I just need to buy a new exhaust shield.

The old one just fell off somewhere.

The only thing I don't like is having to loosen the exhaust bolts & move the exhaust up to get to the oil filter that was just stupid of Yamaha to do that.

I might buy an aftermarket exhaust one day.

If I do will I have to change the jetting since I have a K & N filter also on it.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Just_a_trail_rider

Posted June 28, 2008 - 06:50 AM


Good idea on the exhaust shield. Mine takes a beating. When I didn't have it on, my pipe got dinged.

Yes, if you change the air flow, you will have to adjust the jetting. What year is your wr. I can get to my oil filter without removing the exhaust. I got one of those allen drivers with the ball tip. Or better yet, it might be easier to loosen and move the exhaust can and slightly move the header up and out of the way.

  • marcusmoberg

Posted June 28, 2008 - 11:51 AM


My WR is a 2000.
I don't have to take the Exhaust off I just have to loosen the bolts & move the Exhaust up a little bit to get to the oil filter.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.