5 replies to this topic
  • 44x

Posted June 23, 2008 - 08:48 PM


looking for some info on electrical and charging of battery, 03 wr450, can not seem to keep bateries in this bike.

  • Desracer

Posted June 23, 2008 - 09:37 PM


So are they going dead? how long do they last? Did you put on a voltmeter to see if it charging normally? The owners manual is really pretty good for this. I have a 03 with the stock battery? why it still works ??? but hey I got my money out of it. Add some info on whats going on so we can get you fixed.

  • 44x

Posted June 24, 2008 - 05:34 AM


Yes, battery keeps dying,put a volt meter on while running bike and at idle batery showes 8.32 volts at idle, lower voltage at higher rpm, what is strange when bikes running light is on its at 9.5 volts.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Desracer

Posted June 24, 2008 - 03:45 PM


Your battery is not being charged! You should have 12 volts plus at the battery at all times. When the engine is running 13 to 14 volts or more is normal. Check the stator output if okay, then do the regulator rectifier test. It could be some wire connection is loose. Your owners manual has this information in it on tests to perform. If you do do not have the manual do a search on TT and you should find it.

  • 44x

Posted June 24, 2008 - 06:30 PM


thanks for the info, the most help I have gotten yet.

  • Desracer

Posted June 24, 2008 - 09:15 PM


No problem, good luck!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.