throttle cable problems


3 replies to this topic
  • Just_a_trail_rider

Posted June 15, 2008 - 10:17 PM

#1

My throttle doesn't return back to the correct position. I removed the cover off of the carb and see that theres's two cables, one to turn the throttle (bottom) and one to return things back to their normal position.

i assuming that they both work together. But when I turn the throttle, the top cable on the carb has some slack and doen't push in to the cable sheath like it should.

Is there an adjustment I can do or are new cables needed. I tried with no luck to lube the cables.

  • dazzabb

Posted June 15, 2008 - 10:45 PM

#2

There is an adjuster that is covered in a black sleeve on the opening cable, its about 5" away from the throttle, should be no drama to undo it and tighten out the slack.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • crooks420

Posted June 15, 2008 - 11:21 PM

#3

You might want to lube the cables and clean and re-lube the throttle tube. The new issue of DIRT RIDER has a good "how to" on controls.... do yourself the favor and go buy it.

Jesse

  • kskyles

Posted June 16, 2008 - 09:05 AM

#4

try the adjustment, but i found that cleaning out the throttle body helped out a lot. also, take apart the throttle body and check the top of the cables. the plastic sheathing at the top of the cables had broken.

new cable fixed it. a motion pro replacement was cheap.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.