2000 wr 400 electrical help

1 reply to this topic
  • wayfarer103

Posted June 08, 2008 - 04:18 PM


I just got a 2000 wr 400 last week, i love it and it runs great, the power is unparalleled to any other bike ive owned, it has an after market pipe too, damn things screams!

anyway, i only have one problem with it, the previous owner took off the street kit that was on it and disconnected the head and tail lights, and gave me 2 harnesses and also the regulator. i took the seat, gas tank, etc off today and tried to figure out how to rig it back up, but when it comes to electrical work im sub par.

any help on this would be great

the kill switch also doesnt work, im not sure if its bad, or related to my light problems

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • roushxteam199

Posted June 08, 2008 - 05:55 PM


this sounds like a fun one. Basically you need to find the connectors on the bike first. this is one of those deals where i could probally figure it out if i was there but hard to explain.
1st start to find what conectors go where. you know that one goes to the tail light, 1 in the headlight assembly, one goes to the regualtor/rectifier i believe yours is probally a regulator-rectifier combination. the others plug into the factory harness. the kill switch is disconected i believe where you headlight should be.
hoped i helped


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.