Faulty Ignition Switch

4 replies to this topic
  • kskyles

Posted May 18, 2008 - 02:07 PM


Hi all-

When riding yesterday, I stopped to talk with my buddy. I'm on an '05 WR450. I went to hit the starter button and it was dead. I looked at the ignition switch, and the light was out. I have a fresh battery. After wiggling some more wires and playing with the switch, it lit back up, and I started on my way.

Same thing happened about 10 minutes later. Everything was dry.

This happened before, but my bike was wet. I thought that there was water in some connections.

Anyone have this issue before? I'm thinking the ignition switch is faulty.

  • CORider63

Posted May 18, 2008 - 04:33 PM


The stock Yamaha On/Off switches seem to be really cheap. I've seen two others fail. I replaced mine with a keyed ignition switch before it failed. There are several threads regarding use of a keyed switch that you can search for.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • kskyles

Posted May 19, 2008 - 06:18 AM


I've seen all of the keyed ignition switch threads, and i like the idea of the ttr125 ignition switch. I may go that route.

I'm going to pull it apart tonight to look at it, and try to clean it up.

Is there anything that I should be looking for? Anyone else have any more experience with these.

  • CORider63

Posted May 19, 2008 - 06:46 AM


The problems that I have seen are with the switch, itself, going bad.

  • kskyles

Posted May 19, 2008 - 09:02 AM


thanks. i'll test out the switch and see what happens.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.