07 WR450 cut out in wet conditions


5 replies to this topic
  • neal737

Posted April 09, 2008 - 06:14 PM

#1

Bike has been running great after the AIS kit, Dr. D pipe and other usuall mods. Went riding tonite on muddy and wet track and blew the fuse for starter and it started to cut out alot and backfire(never did this in dry weather). Love the bike but is there something getting wet that i can cover to keep it from cutting out. Thanks.

  • zilon101

Posted August 14, 2008 - 02:55 AM

#2

Hi there do you still have the key ignition on it

  • brad the best

Posted August 14, 2008 - 06:45 AM

#3

never herd of this before so im going to recomend a big tube of di-electric grease . hit every connection with it .

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • WR_Dave

Posted August 14, 2008 - 07:01 AM

#4

A friends bike got water in the kill switch and it was cutting out and backfiring. Disassembled the switch, sealed it up better and no more problems. Check out the kill switch for any tears in the button rubber etc. Just a thought. -- WR Dave.

  • kskyles

Posted August 14, 2008 - 02:18 PM

#5

i had a little issue with this too.

i just cleaned up all the electrical connections with some compressed air and a brush, and applied some dielectric grease on the fittings. solved the issue for me.

if you do that, and check all your switch housings - you'll track it down.

  • neal737

Posted August 15, 2008 - 12:51 PM

#6

Thanks for the help, cleaned and greased and have no more problems. Thanks again.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.