All ye XR Wiring guru's help thy Dumb A$$

5 replies to this topic
  • BBA

Posted April 07, 2008 - 06:27 PM


Ok so I've had this 200w Ricky Stator sitting around for a while and finally decided to do the install on the BRP. I also installed the Ricky Voltage Regulator as well since Im running it on the 200w single side. I also have the Baja Design kit. My problem is now my lights, horn, well, all of the DS kit is not working at all! The bike fires and runs fine but no lights, turn signals or horn. I thought I wired it right but now Im lost and not sure??

I checked the 15amp inline fuse for the DS kit and its fine. Can someone that has both this stator & Baja Design kit on their XRR remove the seat and snap a picture of the wiring and how it all goes? The black/red, brown, and the two coupled blue wires are no brainers but the greens, whites, other brown and orange wires are where I have took a wrong turn. I will send whoever can help me with this some kind of Las Vegas T-shirt of their choice. I hate wiring, personally I would rather go to the Dentist and have teeth pulled than try and wire something. Please help my Dumb A$$ get this straightend out!!:thumbsup:

  • absynth01

Posted April 08, 2008 - 07:05 AM


I've got that setup on my 600R, but am not sure if they are the same. What year bike and is it, and is it 650R or 600R?

  • BBA

Posted April 08, 2008 - 09:46 AM


Its an 02 XR650R. I have the rest of the day off from work so Im going to try and figure it out! Any help would still be very appreciated!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • RipperFox

Posted April 08, 2008 - 10:08 AM


Do you have a multimeter? You can get one for $20, and will use it for the rest of your life and save your self a lot of time and headaches when troubleshooting stuff. Sounds like you want to get it fixed NOW though. I would mail you a extra one I have, with a wiring diagram, that a I having lying around if you would want to wait.

Here's the wiring diagram:thumbsup: All the Baja kit does is tap into that existing White/Yellow wire to get its power.
PIG PEN Keep this site. Haymaker(the owner) is "Double Dog" smart on these XRR's

You XRR guys help me out...All the XRR should have pretty much the same wiring and coloring schemes? Changes from year to year (if any) are not something I dont have any experience with.

I can help you trace the problem from the stator forward. But you need a multimeter to test at the different locations.

Sounds like you are a little intimidated by wiring and electrical. Dont be. It is very simple, and lack of experience is the biggest hurdle. Truely the motor/carb/valve train is more complex than the electrical.

  • cleonard

Posted April 08, 2008 - 10:17 AM


First try it with only one lighting coil. Then work from the coil to the lights. After it's all working parallel the coils.

There are two ways to hook up the lighting coil with both windings. The right way and you get 200 watts. Cross the wires and you get almost nothing.

If one is nearby, you can get a nice little voltmeter at Harbor Freight for $3 or $4.

  • BBA

Posted April 08, 2008 - 07:38 PM


Thanks all for the advice. I figured out where I went wrong with the wiring. Once I went back into the garage and took a hard look at where I went wrong I noticed one of the white wires coming out of the stator was hooked up wrong. The pig has power and lights so everything is good!! :thumbsup:

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.