why so much clutch variation?


12 replies to this topic
  • gbalias

Posted April 04, 2008 - 11:48 AM

#1

on my 2000 426, i did the whole 2001 clutch upgrade. i noticed that the range of temp and the effectiveness of the clutch changes a LOT now. on the original 2000 setup, i could ride all day and never have to adjust the clutch cable or anything.

heres what i noticed. the first race on my new clutch (im talking supermoto only on this bike) i assumed id need to make some adjustements, which i did and all weekend, the bike ran fine. a week later when i started up the bike and rode it, when i released the clutch lever, the clutch was still 'engaged' and it was slipping. when i re-adjusted the cable, it works fine now...but will it move a lot again this weekend? i have another race.

i didnt know if it was due to brand new clutch components and they needed breaking in, or if thats the way they are on the upgrade.

i really wont have time to adjust it on the course obviously. theres no triples i can jump and make changes in the air. :prof:

  • gbalias

Posted April 04, 2008 - 03:30 PM

#2

no one experience this?

  • grayracer513

Posted April 04, 2008 - 03:42 PM

#3

You shouldn't have a lot of change in the adjustment unless the clutch is slipping, it seems to me.

  • gbalias

Posted April 04, 2008 - 05:24 PM

#4

it doesnt slip when its adjusted properly.

its just that it seems when it heats up (so it seems) the clutch has a hard time disengaging. so i have to adjust for it after that. then after it cools, or a few days later, when i ride it, when i let out the clutch lever, itll slip as if the cable is way too tight.




i was hoping it was normal for a new set of plates, but i dont know about this one.

  • gbalias

Posted April 04, 2008 - 08:17 PM

#5

well, ive got a race sunday, so ill just bring my old clutch plates with. if i have major problems, ill just swap out the plates. i just dont think i can get it up to temp around my neighborhood as if i were on the track, so unfortunately...im flyin blind here.

  • grayracer513

Posted April 04, 2008 - 08:19 PM

#6

The new plates were OEM parts?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gbalias

Posted April 05, 2008 - 01:59 AM

#7

ebc if i recall correctly.


you thinking thats the problem?

  • William1

Posted April 05, 2008 - 03:24 AM

#8

Most likely. Some plates swell more than others. To make clutch variations go away (at least not a problem) I install Magura clutch jacks. They compensate for and changes automatically. Plus no cable to clean or lube. One less thing.

  • grayracer513

Posted April 05, 2008 - 07:48 AM

#9

ebc if i recall correctly.


you thinking thats the problem?

Yes. The silicon content of the aluminum core of the friction plates in some after market replacement plates is too low, and this causes excessive expansion when heated.

  • groundpounder450

Posted April 05, 2008 - 07:59 AM

#10

ebc is bunk?

  • grayracer513

Posted April 05, 2008 - 08:16 AM

#11

There are very few aftermarket clutch kits I will trust, Hinson and GYT-R being pretty much the only ones. EBC is not on the list. The latest Barnett stuff is said to be good, but I stopped using them a long time back because I had problems with them. They may have changed since.

  • IDAHOBALLER

Posted April 05, 2008 - 08:56 AM

#12

My clutch on my 08 will go spongy if I slip it a lot in real tight terrain, and has done it to me a couple of times on one particular ride that I was on. I have realized that the 450 doesnt like tight spaces anyways, it needs some room to breath and run like a 450 should.

I agree with Gray, in my experiences with all different types of 450 motors once they get pretty built up they are very hard on clutches and the only clutches I have found that are up to the challenge are the oem stuff. I have never tried any Hinson stuff because that stuff is sooo expensive. I did however try the barnett setup in my YFZ quad and i burnt that clutch up after about the 4th drag pass.

  • gbalias

Posted April 05, 2008 - 10:55 AM

#13

my bike is all stock except a slip on and jetting.

i just went out and flogged it for a while. so far the adjustment i made a few days ago is holding up. ill ride it as is, and just take along my old plates if needed.

thanks a lot guys! :thumbsup:

ill let ya know how it does.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.