Pro Moto Billet SA Problems


10 replies to this topic
  • Smokeslider

Posted March 23, 2008 - 11:50 AM

#1

SO I've got about 12 hours on the PMB endcap and the Spark Arrestor screen separated from the metal rim that holds it in place. I purchased a new one for what seemed like too much money and installed it and got to looking around and noticed that it rattled slightly inside the endcap. I tried putting some RTV Sealant on both sides of the SA Flange and we'll see what happens. I'm thinking that it just rattled apart. Anyone else having problems?
Chad

  • 06crf_er

Posted March 23, 2008 - 11:57 AM

#2

No problems with mine and it's got a lot more than 14 hrs on it. Mine has a machined out section that the SA seats into nicely and doesn't allow any rattling. You sure you've got it in correctly?

  • Smokeslider

Posted March 23, 2008 - 12:00 PM

#3

yeah, just doesn't fit real snug I guess. Try sticking your finger in there and see if you can rattle the SA around, let me know what happens.

  • 06crf_er

Posted March 23, 2008 - 12:03 PM

#4

On my way out to the garage....report back in a couple:thumbsup:

  • 06crf_er

Posted March 23, 2008 - 12:06 PM

#5

Absolutely no movement of my SA. It's tight like a tiger. I wonder if they went a little deep on the machining of yours and it doesn't fit snugly. I bet the silicone will make up the difference.

If not, I'd contact PMB and see what they'll do.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Smokeslider

Posted March 23, 2008 - 12:09 PM

#6

Thanks for the second opinion. I'll see what happens with the new one, must have been a machining problem.

  • 06crf_er

Posted March 23, 2008 - 12:10 PM

#7

Funny man....I just checked out your bike in your garage and we run the same number...random....
Posted Image

  • 06crf_er

Posted March 23, 2008 - 12:13 PM

#8

Where in OR are you?

  • Smokeslider

Posted March 23, 2008 - 12:51 PM

#9

I'm in La Grande now, I had to switch numbers for the OMRA racing series but will always be partial to the #44.

  • 426 NOOB

Posted March 23, 2008 - 03:25 PM

#10

The only problem Ive had with my pmb endcap was that I rounded out the head on one of the allens. Be sure to anti-seize them. Now I have to find new ones.

  • thumpyz

Posted March 23, 2008 - 05:13 PM

#11

I had about 1 hour on mine, and all but 5 of the rivets had sheared off. not sure what the problem is.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.