Decompressor Oil Leak anyone? Anyone?



3 replies to this topic
  • Bryan

Posted April 25, 2002 - 08:12 AM

#1

Has anybody had trouble with an oil leak from their decompressor?
I recently stripped that decompressor guide bolt and after using heli coils and curse words for two weeks, I finally JB welded that sucker in. Now I'm getting an oil leak from the decompressor assembly. Is there a seal or bushing or something on the decompressor that I've possibly hosed?
Man, I hope I can get that guide bolt out after JB welding it in there. Dooooooooooh!

Bryan in Denver...

[ April 25, 2002: Message edited by: Bryan ]

  • lewichris

Posted April 25, 2002 - 08:30 AM

#2

that is the same exact thing that happened to my good friend Idahoan. He did the same as you. he is just riding it and checking the oil pretty often. it is a 1998 and he is getting a new one next year. He is not to worried about it. Why did you loosen it or take it out in the first place???

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Bryan

Posted April 25, 2002 - 08:33 AM

#3

I had to adjust that valve. It was way off. To remove the cover to get to the shim, you must remove that assembly.
It seemed like it was loosing a lot of oil, but it barely changed on the dip stick. Worst case, I can just live with it. But it's such a mess. Especially since I ride in dusty situations here in Denver.

  • lewichris

Posted April 25, 2002 - 10:02 AM

#4

yea that is what tyrel goes through




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.