oil change problem????


3 replies to this topic
  • brianO1YZ426

Posted February 29, 2008 - 06:05 PM

#1

im changing the oil filter on my 426 and the filter was hard to get out. now i cant get it screwed back in, was it just stuck in there before or does it screw in like a cars?? i know this sounds dumb but id like to be sure before i put the filter cap back on:bonk:

  • grayracer513

Posted February 29, 2008 - 08:16 PM

#2

It simply sits in the well, and the cap holds it in place. But a not so dumb thing to look at is whether the rubber base pad from the old filter is still on the filter (where it should be) or stuck to the engine case (where it will interfere with the installation of the cover). Take a look.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • brianO1YZ426

Posted February 29, 2008 - 10:06 PM

#3

Hey thanks man. I checked for the rubber washer and it WAS stuck on the engine case, I took that out and the new one fit a lot better. why would it stick ? was it melting to the case?:smirk:

  • ridinredneck

Posted February 29, 2008 - 10:13 PM

#4

nah. it happens a lot. nothing to worry about. just be sure to check for that every time you change the filter.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.