2004 WR450F engine questions


No replies to this topic
  • The Bomber

Posted February 16, 2008 - 01:23 PM

#1

I am working on this bike for a friend. He has owned the bike since new and always taken good care of it. He trail rides but babies it as well. It has issues starting with the electric start.

I have checked the valve clearence and they are all in spec. on the low side of the spec. though. The spark plug looks good and the compression is at 80 psi. I couldn't find it in his manual but is this normal. My Honda has the auto decompression set up and is at 58psi.

I could not get all the timing marks to line up as the manual describes. At TDC the exhaust mark is above the edge of the head and the intake is below. They are just off a little. My asumption is that the cam chain is stretched. I also read something in the FAQ about the # of pins between the timing gear marks. His is 14 I read 12 for YZ's and 13 for his bike. His manual shows 14.

So is the compression ok for this bike or does it need a top end rebuild? What are your thoughts?

Any help would be appericated.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.