Hey guys help needed again


3 replies to this topic
  • alfie

Posted February 11, 2008 - 06:13 AM

#1

Hi all Ive finally got around to rebuilding my 01 wr 426 top end, its had all the valves done, new cam chain, high compression je piston kit and a hot cam exhaust cam. which has all been set up buy a friend of mine who is a mechanic.
Now the problem ive got is at quarter to half throttle it stutters and pops and when it gets past half throttle it clears and takes off like scaled cat.making it quite hard to ride when trail riding. it also sometimes pops and spits back on the over run. So any help to sort this problem out would be great. its also a stock u s exhaust muffler.

  • William1

Posted February 11, 2008 - 06:59 AM

#2

Check the carb/needle.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • matt4x4

Posted February 11, 2008 - 07:31 AM

#3

Sounds lean, might want to go down 1 notch on the needle clip or up a size on the main jet.

  • maxtherat

Posted February 11, 2008 - 08:14 PM

#4

I would start with what's speced for a YZ needle. Depending on where you live I'd also recommend a 168 to 170 main jet. JD would be the better, yet more expensive option.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.