07 leaking coolant...


12 replies to this topic
  • redswr

Posted February 09, 2008 - 08:24 PM

#1

hey guys... i'm leaking coolent from what looks to be the water pump weep hole and i was told to replace the water pump seal so the coolant doesn't leak into the oil. i bought the part but was wondering if any of you have any coolant leaking from there?

  • clark4131

Posted February 09, 2008 - 08:27 PM

#2

Standard wear and tear item. It isn't a matter of "if" you'll have to replace it, but rather "when." It's not hard to do and it's kind of like learning to do your valves. You need the manual, shaft, impeller, seals, bearing and gasket to do it right...SC

  • redswr

Posted February 09, 2008 - 08:38 PM

#3

ok... i'll pick up those other items. what else do you suggest for a 1,000 mile tune up? all i've done to the bike are regular oil changes and kept the air filter clean since i bought it...

  • JSanfilippo

Posted February 10, 2008 - 12:20 AM

#4

I'll be at 1000 miles within the next couple of months...is this something that typically happens around then or is it on a bike to bike basis? :applause:

  • clark4131

Posted February 10, 2008 - 07:49 AM

#5

It's kind of a hit and miss deal. Some get it early, some late, some not at all. I got mine at the end of the second riding season. It's like losing your virginity...if you're patient, it'll eventually happen for you :applause:...SC

  • JSanfilippo

Posted February 10, 2008 - 02:30 PM

#6

:applause:

Would a boyseen waterpump impeller/cover eliminate the possibility of this happening?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tweav

Posted February 10, 2008 - 03:33 PM

#7

Mine leaked at 300 miles.

  • brad the best

Posted February 10, 2008 - 04:01 PM

#8

mine has never leaked , i think its because i run engine ice . 26$ for coolant but personally it was worth it .

  • redswr

Posted February 10, 2008 - 04:22 PM

#9

Mine leaked at 300 miles.


what all did you replace when yours went out?

mine has never leaked , i think its because i run engine ice . 26$ for coolant but personally it was worth it .


sorry to say but i just bought some of that for my bike and it only ran me $16...

  • brad the best

Posted February 10, 2008 - 05:48 PM

#10

different prices in canada .

  • redswr

Posted February 10, 2008 - 09:11 PM

#11

different prices in canada .


oops... didn't see where you were from.

  • clark4131

Posted February 11, 2008 - 06:12 AM

#12

The problem isn't the impellor, cover or the type of coolant. It's the two little seals. With metal on rubber, something is eventually going to give...SC

  • TheBlackSheep

Posted February 11, 2008 - 01:54 PM

#13

I replaced my seal at 1200 miles/80 hrs. But I still have drops when I shut her down after a ride. I don't know of it's because it's hot or if I did a crappy job replacing the seal?

.......... bahhh :applause:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.