checking linkage/SA?



2 replies to this topic
  • ronco

Posted October 15, 2002 - 09:48 AM

#1

I believe the single needle bearing behind the monoshock bottom is loose, I cleaned/greased then checked all bearings swing arm and monoshock seem tight as well as the bolt through the swing arm and where it attaches to the frame. When the bike is on it's stand I can lift from back of swing arm and seem to get a small amount of movement before the bolt begins to contact the other parts(difficult to explain?) Is all the linkage supposed to be completely without any play at all? I plan to replace the bearing I question soon anyways to see if the looseness dissappears!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • YAMAKAZE

Posted October 15, 2002 - 12:16 PM

#2

If the bearings have not been lubed atleast twice a year since new, you might as well order the complete kit for the swingarm and the lower link...You will find that they are thrashed....

Bonzai :)

  • ronco

Posted October 16, 2002 - 04:45 AM

#3

I last greased everything in March(7mos ago) and before that my friend owned the bike since new, I believe he did PM well, I will take apart everything if the other bearings look good could they still be bad from wear?, I would hate to take out good bearings and I would not want to ruin new ones by leaving worn bearings in. I want to do what's best for the bike so if I need all new bearings I will buy them.
Thanks for taking time to reply!




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.