CDI repair?


30 replies to this topic
  • captb

Posted December 19, 2007 - 04:59 PM

#21

cccccccccccc

I have been having some very annoying issues with my 650L and I think its my CDI. Your NX just dying for no reason? Is there no consistant time of death? Mine just dies at random intervals. Sometimes it will run for a couple hours and sometimes it wont start at all. When mine acts up, I just pull it out and whack it againt the frame a few times. That usually works for a while. Try it.:banghead:


Mine did that, I traced it tio the CDI, if you tapped on it or wiggled the wire connector it would act up, internal CDI connection problem, I replaced it and foam mounted it no more issues (it was a 93XR650L), captb



Hehe, that sounds kinda funny.:busted:



  • diverjp

Posted February 22, 2009 - 02:13 PM

#22

I have an 88 NX250 and was able to repair the CDI. The symptoms were that you would get 1 spark when you crank it. I opened the back (tricky, theres a dutch link that shows photos) and went over whatever solder joints looked bad. One was cracked. Sparks like mad now

  • martinfan30

Posted February 22, 2009 - 02:16 PM

#23

I have an 88 NX250 and was able to repair the CDI. The symptoms were that you would get 1 spark when you crank it. I opened the back (tricky, theres a dutch link that shows photos) and went over whatever solder joints looked bad. One was cracked. Sparks like mad now


Interesting. Do you have the link handy?

  • brianhare

Posted February 22, 2009 - 03:47 PM

#24

I have an 88 NX250 and was able to repair the CDI. The symptoms were that you would get 1 spark when you crank it. I opened the back (tricky, theres a dutch link that shows photos) and went over whatever solder joints looked bad. One was cracked. Sparks like mad now



Now this wouldn`t surprise me in the least,Honda cars have this problem with their DRL Module (daytime running light),you take the board out and a pile of the solder joints on the board are cracked/separated..

The real cure for this is to remove all the old solder and resolder the contacts,on the DRL module you have to use silver solder or it will repeat this separation due to the high heat current load...we refer to this as a ``bad cold solder joint``..

B

  • Captain Midnight

Posted February 23, 2009 - 09:58 AM

#25

I replaced my CDI box with a Megajolt unit. $84.00. Programable curve, with adjustable rev limiter.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • diverjp

Posted February 23, 2009 - 06:26 PM

#26

http://www.motor-for...essages/19436//

This link is a translation tool, copy and paste the text

http://babelfish.altavista.com/

I should have taken photos myself but its all sealed up and back in the bike. The key is to use a dremel with a cutoff disc and just cut through the sides at the very bottom. You want to pull the bottom off without cutting the board (you can see where this happened a bit in the photos)You want to cut just the thickness of the case, like 1/8" or so. Then pry it off with a couple screwdrivers. Be careful. You will then see the bottom of the board covered with potting. It actually will peel off pretty easily. As I said I saw one joint that was definetly cracked and about 6 or 7 others that I touched up. You will need a maginfying glass and a small tip soldeing pencil. After repairing the cold solder joints I covered everything with 100% silicone sealer. and stuck the back cover on and carefully made sure everything was sealed. Sparks like mad now. Good luck.

  • exdirtbiker

Posted February 23, 2009 - 06:39 PM

#27

$170 sounds high... did you shop around? I got a XL600 cdi for $120. new.

My '83 Honda V45 Magna (750) chewed through 3 sets of cdi boxes ( 2 at a time)... :busted: until I found the ground wire to the block (4"long ) looked like a cigarette. I was actually WHITE with corrosion. After I cleaned it, and EVERY other connecor, plug, and switch I could find, I put 600 miles on it without a hickup.
Then sold it to buy the XL600... with a bad cdi !!! :lol: :worthy: :banghead:

  • Desert ATV Rider

Posted May 16, 2009 - 09:09 PM

#28

My Honda TRX250 wouldn't start - had no spark. Everything else checked out okay, so I suspected the CDI box had failed.
After reading the discussing in this forum thread, I successfully repaired my CDI by re-soldering a bad pin connection. Works great now! I used a hacksaw to make four straight cuts about an eighth inch from the edge of the backside of the box, then carefully removed the back of the case and the potting material to expose the circuit board. It was fairly obvious which connection had gone bad - it was discolored, kinda blackened. After the repair, I resealed the box using high temp automotive silicone to re-attach the piece of the outer hard plastic case which I had removed. Then wrapped it up really good with black tape. :doh:
THANKS to everyone for the helpful information! Saved me about $140...

  • HeadTrauma

Posted May 16, 2009 - 09:29 PM

#29

This thread is right up my alley. I don't have a bad CDI(yet), but I am always interested in repairing the unrepairable, like a CDI potted in epoxy. Now I just need someone to send me a few dead CDIs for experimentation...

Hell, I'd really like to know what's on the component side of the pcb.

  • martinfan30

Posted May 17, 2009 - 06:45 AM

#30

My Honda TRX250 wouldn't start - had no spark. Everything else checked out okay, so I suspected the CDI box had failed.
After reading the discussing in this forum thread, I successfully repaired my CDI by re-soldering a bad pin connection. Works great now! I used a hacksaw to make four straight cuts about an eighth inch from the edge of the backside of the box, then carefully removed the back of the case and the potting material to expose the circuit board. It was fairly obvious which connection had gone bad - it was discolored, kinda blackened. After the repair, I resealed the box using high temp automotive silicone to re-attach the piece of the outer hard plastic case which I had removed. Then wrapped it up really good with black tape. :doh:
THANKS to everyone for the helpful information! Saved me about $140...


Is the TRX250 ignition system AC, or DC like the 650L?

This thread is right up my alley. I don't have a bad CDI(yet), but I am always interested in repairing the unrepairable, like a CDI potted in epoxy. Now I just need someone to send me a few dead CDIs for experimentation...

Hell, I'd really like to know what's on the component side of the pcb.


Me too. I think this repair would be pretty easy to accomplish. If you do get one from some helpful donor, I'd love to see pics.

  • Desert ATV Rider

Posted May 17, 2009 - 10:26 AM

#31

According to the wiring diagram, the black/red wire coming from the stator exciter coil to the CDI does have a diode inline. So I guess that would that make it DC going into the CDI, but I'm not sure if this answers your question? The three yellow wires from the stator feed into the rectifier which would convert them to DC also.

I forgot to take any photos. It just looked like the backside of a typical pc board. All that was visible were the soldered end stubs of the wires from the various components.

I agree with ya Head Trauma... There is a certain feeling of accomplishment that you get when making DIY repairs. It's not just the money savings (but that helps too!). It's especially sweet when the repair is on something that is normally not supposed to be repairable.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.