Question about Acerbis 5.8 tank 650L


4 replies to this topic
  • tgstoken

Posted December 14, 2007 - 02:18 PM

#1

After I installed my new Acerbis 5.8 tank on my 650L, the engine now dies on occasion for no apparent reason. I just pulled the plug and it is soaked in gas and DARK/black. It ran perfectly before the tank swap, so it aint my jetting. Anyway, on the my questions. I have both petcocks set to the open/on position, would that cause the carb to suck in too much fuel and flood it? Should I run the new tank with one petcock set to open and the other closed until needed? The bike only has 7500 miles on it and its a great step up from my old KLR250.:banghead:

  • cleonard

Posted December 14, 2007 - 02:27 PM

#2

Does it ever leak gas out the carb overflow? I'm guessing that the float needle valve is not sealing and the float bowl is getting too much gas. It could be crud keeping it open, or just a poor seal. Perhaps a new float needle or fuel filter(s) will fix it.

A quick way to flush the bowl. Petcocks off. Drain float bowl. Leave drain open. Turn on one petcock and let a little drain out. Repeat, but use the other petcock.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • XR650L_Dave

Posted December 14, 2007 - 02:32 PM

#3

2 thoughts-

1) During the tank swap you munged something electrical that has weakened the spark- probably the coil wire.

2) You had a carb float needle that was not sealing well, but well enough. Now that the gas is hitting the carb with more pressure from the taller tank (taller 'head' of gas in tank) its letting too much gas through.

for 1), just check connections, etc.

for 2) hook a piece of clear hose to the carb drain, lift it up above the carb a little, and open the drain and petcock. The level of the gas in the hose should not go higher than the part of the carb where the bowl bolts on.


Dave

  • Coolidge

Posted December 14, 2007 - 02:35 PM

#4

Not sure if you cleaned the tank before install? But maybe a small pc of plastic or ? made its way into carb, and is getting needle stuck, flooding it???
Just a thought? :banghead:

  • tgstoken

Posted December 14, 2007 - 02:40 PM

#5

Just looked over the old plug closely and the end that connect to the coil is bent. I will first swap out plugs and if that doesnt fix it, I will pop open the carb and take a look around. I did not clean the tanks interior prior to use, so maybe some little bit has made its way in there and caused a blockage. Opened the carb and checked around in there and found nothing. I did drill the slide and shim the needle though, while I was in there. I'll put it all back together tomorrow, and see how it works.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.