WR 400 F Radator leaking after 3-5mins idling

2 replies to this topic
  • Richard56

Posted March 31, 2002 - 10:29 PM


I just got my '98 WR 400 F. Can anyone tell me is it normal for radiator/coolant to leak out from the vent hole beside the coolant pump? The bike shop already changed the oil seal and the water seal. The leak still persist. When my bike is idling in neutral gear for 3 to 5 mins, it will puke the coolant out. My radiator cap is 1.1 (stock cap). Everything is in its original condition.
What should I do to solve this problem? Should I change the impeller shaft, the impeller and the bearing? Does the coolant leak into the oil when the seals are broken or do they just puke out thru the vent hole? I heard people saying that the vent hole is an indication that the seal is broken and when it does happened, the coolant will not flow into the engine because of that vent hole design. Is it true? Please help...

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Rich_in_Orlando

Posted April 01, 2002 - 05:02 AM


Mine was leaking just like yours so I changed both seals and the bearing. It still leaked. I replaced the impeller shaft and it stopped leaking.

I think it would be very difficult for the coolant to get into the oil because of the vent hole design. The vent hole doesn't allow any pressure to build up between the two seals.

  • banffboy

Posted April 01, 2002 - 09:01 AM


Had the same problem with my old 98. It was the impellar shaft


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.